Nameconflict: The Scripted JQL Function 'hasSubtask' also exists in JQL Tricks Plugin

Description

*This issue has moved*

This issue has been moved permanently to Adaptavist's Product Support JIRA instance.

All existing users of this instance should have the same username on our Product Support instance. However, you will very likely need to click on the
Can't access your account link in order to reset to a new password.

Both plugins, Scriptrunner and JQL Tricks, have a function with the name 'hasSubtasks'.

If both plugins are installed this function is not available any longer.

See also the JQL Bug: https://j-tricks.atlassian.net/browse/JQLT-174

Please rename this function, or get in contact with the JQL Tricks Developers

Environment

Jira 6.3.9, JQL Tricks 5.3.3 and 5.3.10

Activity

Show:
Kai Kramp
May 8, 2015, 2:12 PM

Hello Jamie,

thank you for the fast answer. We will discuss which plugin has to be disabled.
Please close the issue.

Bets regards from Hamburg, Kai-Peter

Jamie Echlin
May 8, 2015, 1:24 PM

I'm not renaming the SR function. You can disable the function in whichever plugin you don't want to use.

Won't Fix

Assignee

Jamie Echlin

Reporter

Kai Kramp

Internal Complexity

Unknown

Internal Value

Unknown

Affects versions

Priority

Critical