Script Runner not working in JIRA 4.3

Description

*This issue has moved*

This issue has been moved permanently to Adaptavist's Product Support JIRA instance.

All existing users of this instance should have the same username on our Product Support instance. However, you will very likely need to click on the
Can't access your account link in order to reset to a new password.

Hi Jamie,

Been using Groovy scripts for over a year now and we are upgrading to 4.3 from 4.0. In 4.0, I needed 2 plugins: Groovy1.7 and GroovyRunner1.1 were the versions we had. Now in 4.3, it looks like all I should need is GroovyRunner1.7.3. Is this correct, or do I need a new version of Groovy1.7 as well?

Assuming all I need is GroovyRunner1.7.3, I cannot get it to work. A couple of issues:
1. Everytime I restart my JIRA service, the plugin is disable, so I need to go and enable. All of the other plugins stay enabled.
2. When I set up my workflow, I add a validator and choose Script Validator and click "Add". I get to the Add Parameters page, but the box where I would enter my script name is missing. It just says "Add required parameters to the Validator." with Add and Cancel buttons. I saw in a previous issue that JIRA Suite Utilities were causing some problems, so I disabled that plugin but had the same results.

Any suggestions on these 2 problems?

Thanks,
Jeff

Environment

Windows XP

Activity

Show:
Jeff Mommaerts
March 24, 2011, 6:38 AM

It was the groovy runtime that I had been missing. I reused the 1.7 version last night and was able to get things working. I have now upgraded it to the latest 1.7.10. Thanks for your feedback. I am good to go now.

Jamie Echlin
March 23, 2011, 3:11 PM

Final word from me. The versions of both jars that you had will work fine in 4.3, you just won't get the new built-in scripts.

Jamie Echlin
March 23, 2011, 3:08 PM

But yes, you should get 1.7.3 of the plugin, although old versions will work. The groovy jar should be greater or equal to 1.7.4.

Jamie Echlin
March 23, 2011, 3:07 PM

Hi Jeff,

I'm a bit confused. You need the latest version of the plugin which is 1.7.3 as you say. You also need the groovy runtime... you should get the latest on the 1.7 branch which is current 1.7.10, available from http://groovy.codehaus.org/Download . The groovy runtime is not a plugin, it's just a jar that needs to go in web-inf/lib.

> Can you tell me if that version is supported in 4.3? Is there a new version available?

Sounds like you have everything correct and sorted out now?

Jeff Mommaerts
March 23, 2011, 2:39 PM

So, apparently the answer to both of my issues is that, Yes, I still need Groovy1.7 running as a plugin. When I added that, both of my issues above were resolved.

Can you tell me if that version is supported in 4.3? Is there a new version available?

Resolved Locally
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Jamie Echlin

Reporter

Jeff Mommaerts

Internal Complexity

Unknown

Internal Value

Unknown